I Hate Dialysis Message Board
Welcome, Guest. Please login or register.
April 01, 2020, 04:17:24 AM

Login with username, password and session length
Search:     Advanced search
530052 Posts in 33367 Topics by 12373 Members
Latest Member: kbiel
* Home Help Search Login Register
+  I Hate Dialysis Message Board
|-+  Dialysis Discussion
| |-+  Dialysis: Home Dialysis (Moderator: Charlie B53)
| | |-+  Liberty Cycler problems
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Liberty Cycler problems  (Read 2421 times)
lowestcerberus
Newbie
*
Offline Offline

Posts: 1

« on: June 25, 2010, 04:26:56 PM »

I was wondering how many people are having problems with the Liberty Cycler? I will be going on to my 4th machine in 6 months. I get any where from 7 to 12 alarms a night or it goes into alarm but the alarm never sounds, so I don't wake up. Anyone got issues like this?
Logged
*kana*
Full Member
***
Offline Offline

Gender: Female
Posts: 360

« Reply #1 on: July 10, 2010, 04:30:37 PM »

Oooooh yeah, I about lost my mind with my last machine.  It would alarm 8-10 time a night regardless of my postion.  I work full time and it was taking it's toll on me so I exchanged it for a new one.  This one is ok and has min issues.

Mine didn't act up until I went on a trip and the airline tossed it around like a piece of junk.  The machines are all refurbished and used over and over again so it is my belief that once they get abused/worn out they have no way of knowing they need repaired because I'm sure they pass all of their tests etc.   

And Welcome to IHD! 
« Last Edit: July 10, 2010, 04:32:06 PM by *kana* » Logged

PD started 09/08
PKD kidneys removed 06/17/09

Failed donor transplant-donor kidney removed,
suspected cancer so not used 06/17/09

Hemo 06/2009-08/2009

Liberty Cycler-11/09-5/13
Nx Stage-current tx
Diagnosed with SEP 2014
Pages: [1] Go Up Print 
« previous next »
 

Powered by MySQL Powered by PHP SMF 2.0.17 | SMF © 2019, Simple Machines | Terms and Policies Valid XHTML 1.0! Valid CSS!